summaryrefslogtreecommitdiff
path: root/indra/CMakeLists.txt
diff options
context:
space:
mode:
authorLogan Dethrow <log@lindenlab.com>2011-09-13 14:41:00 -0400
committerLogan Dethrow <log@lindenlab.com>2011-09-13 14:41:00 -0400
commit15a3df2f084947fb977e87817f786c7aa35d3af7 (patch)
treec2494c0fff59287efe38c3f0ef72acc6afe0f872 /indra/CMakeLists.txt
parentdc58b5207b3ed92dfcf7ecf16c7844453faac18f (diff)
Always build indra/test, run if LL_TESTS is enabled. Removed python test run command since there are no python tests in the viewer.
Diffstat (limited to 'indra/CMakeLists.txt')
-rw-r--r--indra/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/indra/CMakeLists.txt b/indra/CMakeLists.txt
index 39e33831d2..4b1bf49d07 100644
--- a/indra/CMakeLists.txt
+++ b/indra/CMakeLists.txt
@@ -69,9 +69,8 @@ if (VIEWER)
add_subdirectory(${LIBS_OPEN_PREFIX}llxuixml)
add_subdirectory(${LIBS_OPEN_PREFIX}viewer_components)
- if (LL_TESTS)
- add_subdirectory(${VIEWER_PREFIX}test)
- endif (LL_TESTS)
+ # Legacy C++ tests. Build always, run if LL_TESTS is true.
+ add_subdirectory(${VIEWER_PREFIX}test)
# viewer media plugins
add_subdirectory(${LIBS_OPEN_PREFIX}media_plugins)