summaryrefslogtreecommitdiff
path: root/indra/CMakeLists.txt
diff options
context:
space:
mode:
authorOz Linden <oz@lindenlab.com>2017-07-10 16:30:28 -0400
committerOz Linden <oz@lindenlab.com>2017-07-10 16:30:28 -0400
commitb0d8f3a1ab671668abb98fe1327f0fd73fca0fc7 (patch)
tree3eb0768772b99db06d5cdd2cbf59d201d5f22cf8 /indra/CMakeLists.txt
parent7eb53d4ccbfcb692a2edc7539e651b14c888742e (diff)
MAINT-4532: properly detect Windows 10 in the 64bit build (only - 32bit runs in Windows 8 compatibility mode)
Diffstat (limited to 'indra/CMakeLists.txt')
-rw-r--r--indra/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/indra/CMakeLists.txt b/indra/CMakeLists.txt
index 39f8697e8c..a40b2c0846 100644
--- a/indra/CMakeLists.txt
+++ b/indra/CMakeLists.txt
@@ -3,8 +3,8 @@
# cmake_minimum_required should appear before any
# other commands to guarantee full compatibility
# with the version specified
-## prior to 2.8, the add_custom_target commands used in setting the version did not work correctly
-cmake_minimum_required(VERSION 2.8.8 FATAL_ERROR)
+## prior to 3.4, the Windows manifest handling was missing
+cmake_minimum_required(VERSION 3.4.0 FATAL_ERROR)
set(ROOT_PROJECT_NAME "SecondLife" CACHE STRING
"The root project/makefile/solution name. Defaults to SecondLife.")