summaryrefslogtreecommitdiff
path: root/indra/CMakeLists.txt
diff options
context:
space:
mode:
authorOz Linden <oz@lindenlab.com>2013-04-30 08:57:29 -0400
committerOz Linden <oz@lindenlab.com>2013-04-30 08:57:29 -0400
commit889d02b52d9d53b59e1bab953b8e19a60c49fd4f (patch)
tree7991f8b9b0972027cc2bc7301a99779e9850141f /indra/CMakeLists.txt
parentca7de31a6c5031bb928d283362e96bb63e37ce85 (diff)
parent2ef8fc41e74b6949e02a7715b2b8399094ebd3ea (diff)
merge changes for CHOP-913
Diffstat (limited to 'indra/CMakeLists.txt')
-rwxr-xr-xindra/CMakeLists.txt21
1 files changed, 4 insertions, 17 deletions
diff --git a/indra/CMakeLists.txt b/indra/CMakeLists.txt
index 0a54163644..bdbfc55fa2 100755
--- a/indra/CMakeLists.txt
+++ b/indra/CMakeLists.txt
@@ -3,14 +3,8 @@
# cmake_minimum_required should appear before any
# other commands to guarantee full compatibility
# with the version specified
-
-# The "cmake -E touch" command was released with 2.4.8.
-cmake_minimum_required(VERSION 2.4.8 FATAL_ERROR)
-
-# This makes cmake 2.6 not complain about version 2.4 compatibility.
-if (COMMAND cmake_policy)
- cmake_policy(SET CMP0003 OLD)
-endif (COMMAND cmake_policy)
+## prior to 2.8, the add_custom_target commands used in setting the version did not work correctly
+cmake_minimum_required(VERSION 2.8.8 FATAL_ERROR)
set(ROOT_PROJECT_NAME "SecondLife" CACHE STRING
"The root project/makefile/solution name. Defaults to SecondLife.")
@@ -19,13 +13,7 @@ project(${ROOT_PROJECT_NAME})
set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
include(Variables)
-
-if (DARWIN)
- # 2.6.4 fixes a Mac bug in get_target_property(... "SLPlugin" LOCATION):
- # before that version it returns "pathname/SLPlugin", whereas the correct
- # answer is "pathname/SLPlugin.app/Contents/MacOS/SLPlugin".
- cmake_minimum_required(VERSION 2.6.4 FATAL_ERROR)
-endif (DARWIN)
+include(BuildVersion)
if (NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE RelWithDebInfo CACHE STRING
@@ -90,8 +78,7 @@ if (LINUX)
add_dependencies(viewer linux-crash-logger-strip-target linux-updater)
elseif (DARWIN)
add_subdirectory(${VIEWER_PREFIX}mac_crash_logger)
- add_subdirectory(${VIEWER_PREFIX}mac_updater)
- add_dependencies(viewer mac-updater mac-crash-logger)
+ add_dependencies(viewer mac-crash-logger)
elseif (WINDOWS)
add_subdirectory(${VIEWER_PREFIX}win_crash_logger)
# cmake EXISTS requires an absolute path, see indra/cmake/Variables.cmake